Drush

Using Drush with Drupal 8 on Nethserver

Submitted by Don Robertson on Tue, 15/08/2017 - 10:18

I have not used Drush much with Drupal, but Drupal 8 makes it harder get away without it. Unfortunately, Nethserver's default PHP version is 5.4.

And to use Drupal (or Nextserver, and other PHP based systems), PHP needs to be at least 5.6. The solution is to use the the Php-SCL module. 

But when running Drush from the command line, it still uses the default 5.4 version, so you need to run it like so:

/usr/bin/php56 /usr/local/bin/drush